Interactive apps don't show up in menu

Hi,
I’ve got an OOD 1.6 server running on my cluster and I’m setting up an OOD 3.1 server. I’ve got the bc_desktop app running and it shows up on my Interactive Apps menu. That works fine, I can launch the desktop and it connects to a compute node. Now I’m moving on to bringing over my interactive apps. When I copy over my RStudio app from the old server to /var/www/ood/apps/sys/RStudio on the new server nothing comes up on the interactive apps menu. The apps are owned by root:root and everything is 755 for directories or 644 for files. All the things like the files and shell menus that exist in that directory work fine, but I can’t see my RStudio app. Any ideas on how to make it populate? I’ve restarted httpd.

Rob

I’d try to restart your web server in the Help menu at the top right and see if that does anything. You’re intuition about file permissions is correct - so it seems you should be able to read the files - i’m just wondering if the older result was cached.

I restarted via help, still nothing.
I’ve tried with another web browser as well.

OK - it could see the app as being invalid. It does a spot check on the cluster you have enabled. Does this Rstudio application use a cluster that you’ve not setup yet?

Also just as a quick sanity check, I’d hop on that machine as you’re regular non-root user and see if you can ls on that directory and the files inside it.That’ll at least confirm that regular users can indeed see the files.

It was a capitalization error. The old server had the cluster defined as E2, new one is defined as e2. Now it’s showing up. Thanks!!

1 Like