Is it safe to erase old ondemand-gem RPMs?

I have a plethera of older ondemand-gem rpms, going back to 1.7.11-1.7.11-1.el7.x86_64. Is there any reason to keep all these old gem RPMs around?

Nothing outside of OpenOnDemand uses ruby on my OOD servers.

If you are running 2.0.x, I would say you should be safe. If we have dependencies on those old RPMS, then we have a huge problem.

The RPMs are built as a stand alone unit base on Release number. you should be good to remove the old ones.

Please let us know if it causes you problems. :wink:

Thanks,
-gerald

I removed the following with no ill effects, so the asnwer appears to be “yes, safe to remove”.

ondemand-gems-1.7.11-1.7.11-1.el7.x86_64
ondemand-gems-1.8.12-1.8.12-1.el7.x86_64
ondemand-gems-1.8.20-1.8.20-1.el7.x86_64
ondemand-gems-1.8.18-1.8.18-1.el7.x86_64
ondemand-gems-1.7.14-1.7.14-1.el7.x86_64
ondemand-gems-1.7.18-1.7.18-1.el7.x86_64
ondemand-gems-2.0.16-2.0.16-1.el7.x86_64
ondemand-gems-2.0.17-2.0.17-1.el7.x86_64
ondemand-gems-2.0.18-2.0.18-1.el7.x86_64
ondemand-gems-2.0.13-2.0.13-1.el7.x86_64```

Thanks for the follow up Ric!