loginLogo not being found

I have updated the old_portal.yml file to customise the login page.

I have tried to update the loginLogo:

  frontend:
    issuer: "MyCenter OnDemand"
    extra:
#      navLogo: "/path/to/custom/nav-logo.png"
      loginLogo: "/var/www/ood/public/uos_logo_white_small.png"
      loginTitle: "Log in with your University username and password"
      loginButtonText: "Log in with your University username and password."
      usernamePlaceholder: "center-username"
      passwordPlaceholder: "center-password"

But it doesn’t seem to find the logo:

Can anyone see why?

Hey sorry for the trouble. I am going to start with the most silly question, have you double checked the file is there (I know that’s annoying to ask, but I just need to check). If so, what are the permissions on the file and what is the ownership? If that still looks good it may be a bug on our end.

Hi @travert - yes the file was there. It is used in the dash too.

In the end I have managed to get it to display by creating a theme and copying it there as suggested here (though I did also get it to work in the ood_portal.yml file by using the server address followed by the path: "loginLogo: “https://myserver.ac.uk/public/my_logo_small.png

Glad you got it to work! Reading those docs I will say, it doesn’t exactly seem clear you needed to do that (but clearly you did), nor is it clear to me if you can customize that default ondemand theme, but I am not a smart man. Maybe it reads differently to others.

Also not sure why the url worked but not the path as the docs seem to want. I’m going to still open an issue against this as it is not expected to use a url for this to work, so there may still be a bug there.

1 Like