Nginx_stage error after upgrading from 1.6 to 1.7

I recently upgraded from 1.6 to 1.7 by following the guide here. I also followed the optional step 5 of removing old dependencies from prior versions of OOD.

After the upgrade, my pun started up without problem. I then logged in and out and restated the pun and everything seemed to work ok. Later in the day, presumably after my pun had been shut down, I tried to reach the site again. I was able to authenticate like before, but was then met with the following error:

Error -- undefined method `disable_bundle_user_config' for NginxStage:Module
Run 'nginx_stage --help' to see a full list of available command line options.

It seems as though I have an older version of nginx_stage that is missing some newer features. What is the best way to go about fixing this?

Where is this error being displayed? Is it cron job output or in a log or ??

Also, have you rebooted since doing the “yum erase” to make sure there isn’t something running that was deleted in the cleanup.

That method “disable_bundle_user_config” was added in this commit

cat /opt/ood/VERSION should show v1.7.11 and

$ grep disable_bundle_user_config /opt/ood/nginx_stage/lib/nginx_stage/views/pun_config_view.rb
    def disable_bundle_user_config?

Maybe verify that /opt/ood/nginx_stage/lib/nginx_stage/views/ file wasn’t added?

I do see that the version is 1.7.11 . I also do not see

[tbpetersen]# cat /opt/ood/VERSION
[tbpetersen]# ls /opt/ood/nginx_stage/lib/nginx_stage/views/ -la
total 20
drwxr-xr-x 2 root root 4096 May 18 14:57 .
drwxr-xr-x 4 root root 4096 May 18 15:25 ..
-rw-r--r-- 1 root root 1343 Apr 23 19:25 app_config_view.rb
-rw-r--r-- 1 root root 5297 Apr 23 19:25 pun_config_view.rb

The error is being displayed in the web browser after I successfully authenticate.


I can’t remember if I rebooted after the upgrade, so I just tried rebooting to make sure. I am still seeing the same error when I try to load the page again.

Ah sorry NginxStage#disable_bundle_user_config is defined here:

$ grep disable_bundle /opt/ood/nginx_stage/lib/nginx_stage/configuration.rb
    attr_accessor :disable_bundle_user_config
      self.disable_bundle_user_config = true

What happens when you do grep disable_bundle /opt/ood/nginx_stage/lib/nginx_stage/configuration.rb and might there be a grep disable_bundle /opt/ood/nginx_stage/lib/nginx_stage/ file?

The grep command finds no matching results. I don’t see a file there.

-bash-4.2$ grep disable_bundle /opt/ood/nginx_stage/lib/nginx_stage/configuration.rb
-bash-4.2$ ls -la /opt/ood/nginx_stage/lib/nginx_stage/
total 76
drwxr-xr-x 4 root root  4096 May 18 15:25 .
drwxr-xr-x 3 root root  4096 May 18 14:57 ..
-rw-r--r-- 1 root root  3860 Apr 23 19:25 application.rb
-rw-r--r-- 1 root root 18068 May 18 15:25 configuration.rb
-rw-r--r-- 1 root root  1747 Apr 23 19:25 errors.rb
-rw-r--r-- 1 root root  2250 Apr 23 19:25 generator_helpers.rb
-rw-r--r-- 1 root root  4582 Apr 23 19:25 generator.rb
drwxr-xr-x 2 root root  4096 May 18 14:57 generators
-rw-r--r-- 1 root root  1303 Apr 23 19:25 pid_file.rb
-rw-r--r-- 1 root root  1194 Apr 23 19:25 secret_key_base_file.rb
-rw-r--r-- 1 root root  1887 Apr 23 19:25 socket_file.rb
-rw-r--r-- 1 root root  1924 Apr 23 19:25 user.rb
-rw-r--r-- 1 root root    78 Apr 23 19:25 version.rb
drwxr-xr-x 2 root root  4096 May 18 14:57 views