No Default Dashboard Website

Not sure if anyone can help me but I obviously don’t know what I’m doing. I’ve done the rpm install for ood several times and tried the source install once following directions from (Installation — Open OnDemand 1.8.12 documentation). No matter what I’ve done, I still cannot get the default dashboard site to show up. I have the server name/ip in our org’s DNS and have the hosts file populated with the IP and server name and CNAME.

I have the FQDN entered in the /etc/ood/config/ood_portal.yml under the servername section. I’ve tried with just the server name as well without the uthscsa.edu with the same results.

From /var/log/httpd24/error_log:

[Wed Apr 27 09:41:43.365343 2022] [mpm_worker:notice] [pid 30508:tid 140307746322624] AH00296: caught SIGWINCH, shutting down gracefully
[Wed Apr 27 09:41:43.815931 2022] [suexec:notice] [pid 31181:tid 139938193848512] AH01232: suEXEC mechanism enabled (wrapper: /opt/rh/httpd24/root/usr/sbin/suexec)
[Wed Apr 27 09:41:43.842683 2022] [lbmethod_heartbeat:notice] [pid 31181:tid 139938193848512] AH02282: No slotmem from mod_heartmonitor
[Wed Apr 27 09:41:43.849218 2022] [mpm_worker:notice] [pid 31181:tid 139938193848512] AH00292: Apache/2.4.34 (Red Hat) OpenSSL/1.0.2k-fips configured – resuming normal operations
[Wed Apr 27 09:41:43.849257 2022] [core:notice] [pid 31181:tid 139938193848512] AH00094: Command line: ‘/opt/rh/httpd24/root/usr/sbin/httpd -D FOREGROUND’

From /var/log/httpd24/error.log:

[Wed Apr 27 09:41:43.846640 2022] [auth_openidc:warn] [pid 31181:tid 139938193848512] oidc_check_config_openid_openidc: the URL scheme (http) of the configured OIDCProviderMetadataURL SHOULD be “https” for security reasons!
[Wed Apr 27 09:41:43.846651 2022] [auth_openidc:warn] [pid 31181:tid 139938193848512] oidc_check_config_openid_openidc: the URL scheme (http) of the configured OIDCRedirectURI SHOULD be “https” for security reasons (moreover: some Providers may reject non-HTTPS URLs)

From /var/log/httpd24/ssl_access_log:

x.x.x.x - - [27/Apr/2022:09:42:08 -0500] “GET /pun/dashboard HTTP/1.1” 404 196
x.x.x.x - - [27/Apr/2022:09:44:15 -0500] “GET /pun/dashboard HTTP/1.1” 404 196
x.x.x.x - - [27/Apr/2022:09:44:15 -0500] “GET /favicon.ico HTTP/1.1” 404 196
x.x.x.x - - [27/Apr/2022:09:44:23 -0500] “GET /pun/sys/dashboard HTTP/1.1” 404 196

From /var/log/httpd24/ssl_error_log:

[Wed Apr 27 08:54:44.880112 2022] [ssl:warn] [pid 30508:tid 140307746322624] AH01909: servername.uthscsa.edu:443:0 server certificate does NOT include an ID which matches the server name
[Wed Apr 27 08:54:44.905641 2022] [ssl:warn] [pid 30508:tid 140307746322624] AH01909: servername.uthscsa.edu:443:0 server certificate does NOT include an ID which matches the server name
[Wed Apr 27 09:41:43.815339 2022] [ssl:warn] [pid 31181:tid 139938193848512] AH01909: servername.uthscsa.edu:443:0 server certificate does NOT include an ID which matches the server name
[Wed Apr 27 09:41:43.842094 2022] [ssl:warn] [pid 31181:tid 139938193848512] AH01909: servername.uthscsa.edu:443:0 server certificate does NOT include an ID which matches the server name

The cert is self-signed with just the servername.

I’ve disabled IPv6, firewalld and selinux.

[root@servername config]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
Loaded: loaded (/usr/lib/systemd/system/firewalld.service; disabled; vendor preset: enabled)
Active: inactive (dead)
Docs: man:firewalld(1)

[root@servername config]# sestatus
SELinux status: disabled

Services:
[root@servername ~]# systemctl status httpd24-httpd
● httpd24-httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd24-httpd.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/httpd24-httpd.service.d
└─ood-portal.conf, ood.conf
Active: active (running) since Wed 2022-04-27 09:58:20 CDT; 3s ago
Process: 31862 ExecStop=/opt/rh/httpd24/root/usr/sbin/httpd-scl-wrapper $OPTIONS -k graceful-stop (code=exited, status=0/SUCCESS)
Process: 31865 ExecStartPre=/opt/ood/ood-portal-generator/sbin/update_ood_portal --rpm (code=exited, status=0/SUCCESS)
Main PID: 31893 (httpd)
Status: “Processing requests…”
CGroup: /system.slice/httpd24-httpd.service
├─31893 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─31894 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─31895 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─31896 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
└─31925 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND

Apr 27 09:58:20 servername systemd[1]: Starting The Apache HTTP Server…
Apr 27 09:58:20 servername update_ood_portal[31865]: No change in Apache config.
Apr 27 09:58:20 servername update_ood_portal[31865]: No change in the Dex config.
Apr 27 09:58:20 servername systemd[1]: Started The Apache HTTP Server.

[root@servername config]# systemctl status ondemand-dex
● ondemand-dex.service - OnDemand Dex - A federated OpenID Connect provider packaged for OnDemand
Loaded: loaded (/usr/lib/systemd/system/ondemand-dex.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2022-04-25 07:52:11 CDT; 2 days ago
Main PID: 17724 (ondemand-dex)
CGroup: /system.slice/ondemand-dex.service
└─17724 /usr/sbin/ondemand-dex serve /etc/ood/dex/config.yaml

Apr 26 09:36:13 servername ondemand-dex[17724]: time=“2022-04-26T14:36:13Z” level=info msg=“keys expired, rotating”
Apr 26 09:36:13servername ondemand-dex[17724]: time=“2022-04-26T14:36:13Z” level=info msg=“keys rotated, next rotation: 2022-04-26 20:36:13.864061454 +0000 UTC”
Apr 26 15:36:14 servername ondemand-dex[17724]: time=“2022-04-26T20:36:14Z” level=info msg=“keys expired, rotating”
Apr 26 15:36:14 servername ondemand-dex[17724]: time=“2022-04-26T20:36:14Z” level=info msg=“keys rotated, next rotation: 2022-04-27 02:36:14.303406136 +0000 UTC”
Apr 26 21:36:14 servername ondemand-dex[17724]: time=“2022-04-27T02:36:14Z” level=info msg=“keys expired, rotating”
Apr 26 21:36:14 servername ondemand-dex[17724]: time=“2022-04-27T02:36:14Z” level=info msg=“keys rotated, next rotation: 2022-04-27 08:36:14.767143625 +0000 UTC”
Apr 27 03:36:14 servername ondemand-dex[17724]: time=“2022-04-27T08:36:14Z” level=info msg=“keys expired, rotating”
Apr 27 03:36:15 servername ondemand-dex[17724]: time=“2022-04-27T08:36:15Z” level=info msg=“keys rotated, next rotation: 2022-04-27 14:36:15.059150863 +0000 UTC”
Apr 27 09:36:15 servername ondemand-dex[17724]: time=“2022-04-27T14:36:15Z” level=info msg=“keys expired, rotating”
Apr 27 09:36:15 servername ondemand-dex[17724]: time=“2022-04-27T14:36:15Z” level=info msg=“keys rotated, next rotation: 2022-04-27 20:36:15.411553125 +0000 UTC”

Let me know if any other piece of info is needed.

Thanks in advance for any assistance.

Ravnell

New to HPC btw

Hi Ravnell.

Welcome! Thanks for posting. Before getting too deep into this, is there a specific reason you are using Open OnDemand version 1.8 instead of the latest version (2.x)?

Thanks,
-gerald

Truthfully, I just saw a post with ver. 2.0 but documentation was still being worked on. I’ll admit, I haven’t crawled this discord save for my particular issue. If you think ver. 2.0 will be better for me, I’ll be more than happy to give it a go. Tired of spinning my wheels right now. lol. If you can point me to the right documentation for 2.0 and I’ll reset my server and start over.

Thank you for replying so fast.

Ravnell

Absolutely. Please use version 2.0. I think you’ll have more success. Either way, at least you are using the latest version and all the good that comes with it.

We’re here to help, so please do not feel shy about asking for that help.

Thanks,
-gerald

Sorry. Here’s the link for the latest documentation which includes 2.0

https://osc.github.io/ood-documentation/latest/index.html

1 Like

Thank you! Hopefully I can get this going with no issue.

Ravnell

1 Like