Reinstall ood dashboard can not start

Hi, I just reinstalled open ondemand, however, the httpd24 used “/opt/rh/httpd24/root/var/www/html/index.html” rather than OOD dashboard, would you please give me some guidance?

[root@hal9000 ~]# systemctl status httpd24-httpd.service -l
● httpd24-httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd24-httpd.service; enabled; vendor preset: disabled)
Drop-In: /etc/systemd/system/httpd24-httpd.service.d
└─ood-portal.conf, ood.conf
Active: active (running) since Thu 2020-08-06 23:16:43 CDT; 1min 4s ago
Process: 1088 ExecStop=/opt/rh/httpd24/root/usr/sbin/httpd-scl-wrapper $OPTIONS -k graceful-stop (code=exited, status=0/SUCCESS)
Process: 1091 ExecStartPre=/opt/ood/ood-portal-generator/sbin/update_ood_portal --rpm (code=exited, status=0/SUCCESS)
Main PID: 1124 (httpd)
Status: “Total requests: 1380; Idle/Busy workers 76/23;Requests/sec: 24.2; Bytes served/sec: 86KB/sec”
Tasks: 89
CGroup: /system.slice/httpd24-httpd.service
├─1124 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1125 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1126 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1129 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1174 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1181 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1182 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1205 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1206 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1225 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1232 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
├─1233 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND
└─1288 /opt/rh/httpd24/root/usr/sbin/httpd -DFOREGROUND

Aug 06 23:16:43 hal9000 systemd[1]: Starting The Apache HTTP Server…
Aug 06 23:16:43 hal9000 update_ood_portal[1091]: No change in Apache config.
Aug 06 23:16:43 hal9000 httpd-scl-wrapper[1124]: AH00558: httpd: Could not reliably determine the server’s fully qualified domain name, using Set the ‘ServerName’ directive globally to suppress this message
Aug 06 23:16:43 hal9000 systemd[1]: Started The Apache HTTP Server.

Thank you in advance,


Maybe a new file was added to /opt/rh/httpd24/root/etc/httpd/conf.d that specifies to serve files from /opt/rh/httpd24/root/var/www/html/? Also in our deployment /opt/rh/httpd24/root/var/www/html/ is an empty directory. Maybe removing /opt/rh/httpd24/root/var/www/html/index.html would help.

Thank you, I changed the ood-portal.conf, and everything worked except interactve jobs, after click the connection button, the webpage went “”, with 404 Not Found. Would you please help me fix it?



Which interactive application are you trying to launch?

We found the problem, it was the reverse proxy problem.

Just started experiencing the same issue with the 404 errors on interactive apps and nothing has changed as far as i know. What was the issue with the reverse proxy that was causing this problem?

My guess is it’s these 4 configs in /etc/ood/config/ood_portal.yml (likely use_rewrites) that you need to update. Did your re-install reconfigure that file as well? Again, setting use_rewrites to true is likely the cause.

use_rewrites: false
node_uri: null
rnode_uri: null
host_regex: '[^/]+'

Fixed the issue, but don’t quite understand why the fix works. I changed the host_regex to include the fully qualified node name according to the cluster and it has started to work again. Nothing has changed on this server that should have affected name resolution. We did update OnDemand to address the most recent CVE issue

I have had the following variables setup as follows since install and was working up until I checked today:

Before fix

#use_rewrites: true (defaults to true)
node_uri: /node
rnode_uri: /rnode
host_regex: 'clustername-[abc]\d\d\d'

After fix:

#use_rewrites: true (defaults to true)
node_uri: /node
rnode_uri: /rnode
host_regex: 'clustername-[abc]\d\d\d.subdomain.domain.tld'