Problem using hpc-toolset-tutorial demo

Hi,

I am trying to use the demo at GitHub - ubccr/hpc-toolset-tutorial: Tutorial for installing Open XDMoD, OnDemand, & ColdFront

The problem is the machine I am running it on does not have browsers or graphical access (why don’t I run it on my desktop machine you ask? That is a whole other thing that I may post about later.).

So I can’t access these containers via localhost from my desktop machine. When I go to https://the-hostname:3443 it redirects to https://localhost:3443.

I exec’d into the ondemand container (which is the one I want to use in a demo) and edited /etc/ood/config/ood_portal.yml to change the servername from localhost to the FQDN of my host name. I then ran /opt/ood/ood-portal-generator/sbin/update_ood_portal which suggested restarting the web server with sudo systemctl try-restart httpd24-httpd.service httpd24-htcacheclean.service but that command gives me:

Failed to get D-Bus connection: Operation not permitted

Some googling suggested that I needed to run the container with privileged: true but I added that to the docker-compose.yml and restarted the containers and I am getting the same error.

Any suggestions?
Thanks

Yea I just went through a bunch of trouble with our own container. My guess is you need cgroup v2 enabled on your machine to be able to restart systemd in the container. But then again - I wonder why it was able to come up at all in the first place but then not be able to restart? When I was having issues it was just with bringing up systemd in the first place, no issues restarting it.

Thanks. I’m not sure how to enable cgroup v2 on this machine? It’s just an AWS EC2 instance running ubuntu 22.04 but it could really be any distro/version if that makes it easier…

It’s a boot parameter. I don’t know if you can edit ec2’s kernel boot parameters or not.