Proxy error when downloading folders and files under "Home Directory" of "File" menu in open ondemand

Hi Support,

When I download folders containing 5417 files and 70 sub-folders from “Home Directory” in “Files” menu, with a total size of 1.08GB, I occasionally encounter the following proxy timeout error. For example, when I attempt to download the folder three times, it fails one or two times out of the three.

This is quite frustrating. Could you please tell me what caused of this problem and suggest potential solutions? For instance, tune the web server settings or adjust the timeout value in OnDemand, etc?

OS Version: Rocky version 8.8
The Open OnDemand version is 3.0.3

Thanks

I’ll have to try to replicate, but I’d ask what you see in both the apache logs and the ondemand-nginx logs to indicate what the error may have been.

:man_facepalming: I don’t have to replicate or see errors - I misread the error in your very first post. It’s failing to determine the directory size using du. So I’d guess it’s an issue of your machine querying the filesystem (again through du).

This du command times out after 5 seconds which is what’s throwing this error for you. Turns out, there’s a configuration OOD_DOWNLOAD_DIR_TIMEOUT_SECONDS which you can use in your env file to set that to 10 or similar.

Hi Jeff,

Thanks for your reply. And, I tried this using the following steps but the proxy error still exists,

  1. On Open OnDemand server, using ssh terminal, login as my account and go to my home directory
  2. Enter a command “echo $SHELL”
  3. Confirmed “/usr/bin/bash” is used
  4. Enter a command “nano .bashrc”
  5. Enter “export OOD_DOWNLOAD_DIR_TIMEOUT_SECONDS=300” in the .bashrc file
  6. Logout and Login
  7. Enter a command “echo $OOD_DOWNLOAD_DIR_TIMEOUT_SECONDS” to confirm the setting is applied (e.g. 300 sec)
  8. Go to Files menu to download the folder again
  9. The proxy error still exists
    image

Could you please check my steps are correct and how to solve this issue? Thanks

It’s not your .bashrc you need to modify. It’s the system’s environment config at /etc/ood/config/apps/dashboard/env.

See here for a similar config on limiting the size of downloads.

https://osc.github.io/ood-documentation/latest/customizations.html?#set-download-limits

Hi Jeff,

Thanks for your reminder.