XdMoD missing after 1.8.18 update

I don’t have many systems I tried this on, but, it seems that after the 1.8.18 update we are not seeing the XdMoD data on the Dashboard, when running on Chrome and Firefox on Linux (CentOS 7, my desktop and our clusters), while, it does show OK on Windows (my laptop).

Our production instance, which is still on 1.8.12, is showing the XdMoD fine in all the above mentioned browsers.

Any thought about that?


To update, my colleagues with Mac see the correct behavior in 1.8.18, so, the issue seems to be only with Linux. I asked others around with Linux workstations to try this to confirm what I see.

I can replicate using a virtual desktop (through on demand!).

It’s an issue with the browser, and an update we pushed. The javascript engine for Firefox 68.6 doesn’t like the dots in this expression "filters": {"person": user?.results?.person_id} which must mean it’s a feature in a newer version of javascript. (I run Linux with FF 81, so must have been added somewhere in between).

I’ll dig a little more to figure out the exact versions of javascript/browser combinations that enabled this feature.

Here are the Mozilla docs on the feature. Looks like you need FF 74. Though we may actually change it because it doesn’t seem work at all for some mobile browsers (FF and Opera on android)

I’ve created this github ticket for this issue. Thanks for letting us know!