Adding cluster as a desktop option

Working through and the dropdown menu is not showing up on the OOD desktop.

Here is the /etc/ood/config/apps/bc_desktop/ivy.yml file

title: “Ivy Desktop”
cluster: “Ivy Cluster”

and the /etc/ood/config/clusters.d/ivy.yml file

title: “Ivy Cluster”
host: “”

Also changed the name of cluster attribute (set cluster: “ivy”) to match the name of the files ivy.yml but it still doesn’t show the pulldown menu.

You would need cluster: "ivy".

I just did a super simple test and this worked, assuming the cluster owens_login.yml exists and is valid.

title: "Super Simple login"
cluster: "owens_login"

The big one is probably making sure ivy.yml is complete (v2.job.adapter at least has to exist).

Also remember to refresh the webpage and you should probably refresh the web server (the restart webserver option near the top right) too if you’re working in ‘production’ mode (putting these files in /etc/ood/config/apps/bc_desktop).

Added the v2.job.adapter section and it is now showing.

When I try to access the shell via the dashboard it is telling me that authentication is failing. Would you like me to open a new thread?

Awesome. Sure if you could!

But I could start to help you out here anyhow. ssh works by just running the ssh command, so you can try to debug that by running ssh from a terminal session. The source is the ondemand webserver and the destination will be will be whatever v2.job.login of that particular cluster is.

Also attach any screenshots or text you have. It really isn’t much more than straight ssh <host> , we don’t even specify the user because ssh will use whatever $USER is.

I will go ahead and start a new thread.