Building from source instructions. 2nd page instructions don't work forUbuntu. Any help?

Hi - I’m trying to build from the source for Ubuntu 20. I finished the first page (after installing Ruby 2.7 from a non-ubuntu repository)

However, the 2nd page has instructions for Apache that don’t work. The first command doesn’t work because it refers to a non-existent directory, /opt/rh/httpd24/service-environment

And the bottom command issues this error:

/opt/ood/ood-portal-generator/sbin/update_ood_portal
Traceback (most recent call last): …
/usr/lib/ruby/2.7.0/rubygems/core_ext/kernel_require.rb:92:in `require’: cannot load such file – bcrypt (LoadError)

Also, the “touch” commands for nginx, don’t work, because the directory /var/lib/ondemand-nginx/config/apps/sys doesn’t exist. How do they get created?

Thanks for any help. - Mark

I would try the build again using this version of the docs:
https://osc.github.io/ood-documentation/develop/installation/install-software.html#

That should give more clear instructions for ubuntu. The directory you mentioned as missing is a red hat thing, so that would be expected to be missing on a debian system.

As for the error, looks like bcrypt is missing, which is likely from the dependencies not being setup right. The docs above are the develop branch and being released soon, but have better coverage around an Ubuntu build and should provide better guidance to start.

Hi - Thanks for responding! I tried the commands on that page, but it can’t find the .deb file:

root@gpu:~# wget -O /tmp/ondemand-release-web_2.0.0_all.deb https://apt.osc.edu/ondemand/2.0/ondemand-release-web_2.0.0_all.deb
–2022-05-19 15:52:18-- https://apt.osc.edu/ondemand/2.0/ondemand-release-web_2.0.0_all.deb
Resolving apt.osc.edu (apt.osc.edu)… 192.148.247.146
Connecting to apt.osc.edu (apt.osc.edu)|192.148.247.146|:443… connected.
HTTP request sent, awaiting response… 404 Not Found
2022-05-19 15:52:18 ERROR 404: Not Found.

Ha, yeah sorry, because that’s under development it looks like that part of the infrastructure isn’t there yet for the debian package.

The only other option I can think of is an Ansible role that uses ubuntu but even that is not supported fully yet, but I think it’s on the road map possibly? I’m not really sure and can’t find much on it myself.

@jeff.ohrstrom or @tdockendorf you all probably know more about this.

We’re not going to ship .deb files to Ubuntu 18.

You can use ansible to install it from the source and indeed - I just patched & released this today to fix that bcrypt issue that you’re running into.

Oh but we will ship .deb files to Ubuntu 20 and 22 if you’re able to get a VM with that OS it’s going to be much easier.

What’s more - you won’t even be able to build 2.1 on Ubuntu 18. You’ll be stuck on that version for as long as you have that OS.

Sorry for the confusion. If you’re on Ubuntu 20 you can follow these instructions to install our nightly. The link Travis gave was from our documentation pointing to 2.1 which isn’t released yet. Nightly just has a bug fix so it should be fairly stable.

wget -O /tmp/ondemand-release.deb https://apt.osc.edu/ondemand/latest/ondemand-release-web-latest_2_all.deb
apt install -y /tmp/ondemand-release.deb
apt install -y apt-transport-https
echo "deb [arch=amd64] https://apt.osc.edu/ondemand/nightly/web/apt focal main" >> /etc/apt/sources.list.d/ondemand-web.list
apt update
apt install ondemand

Thanks! That worked. Now I have to actually configure it. :slight_smile:

Hi - Does this Ubuntu install of ondemand include dex? We would like ldap authentication of ood. Is this possible? Thanks. - Mark

Yes we provide an ondemand-dex deb package as well.

https://yum.osc.edu/ondemand/latest/web/apt/pool/focal/