Navbar Apps customization not working

Hi! I wanted to try to use a custom navbar for the apps. I tried this configuration: Customizations — Open OnDemand 3.0.3 documentation
But it doesn’t work as expected, I can configure only the apps directly under the “sys” folder. So, an app item like: sys/PATH/* doesn’t produce any entry in the menu. I also can’t see anything useful in the logs. Does anyone tried this customization and have an idea about what can be the problem?

Can you share the configuration you’re trying to use and a couple example app names that you’d like captured through the configuration.

Configuration is the same as the example in the documentation, that’s why I was not adding anything about it in the previous message.
Here what I did.
I have an rstudio interactive application in a folder. I copy to the sys app path:

$ cp -ar rstudio /var/www/ood/apps/sys/rstudio1
$ cp -ar rstudio /var/www/ood/apps/sys/rstudio2

with this configuration:

  - title: "My Apps"
    icon: "fas://window-restore"
      - "sys/rstudio*"

the menus shows up.
Screenshot 2024-04-10 at 17.13.22

I tried then to add the 2 folders in an “rstudio” folder like in the example I mentioned.

$ mkdir /var/www/ood/apps/sys/rstudio
$ cp -ar cp -ar rstudio /var/www/ood/apps/sys/rstudio/rstudio1
$ cp -ar cp -ar rstudio /var/www/ood/apps/sys/rstudio/rstudio2

and change the configuration like this:

  - title: "My Apps"
    icon: "fas://window-restore"
      - "sys/rstudio/*"

This doesn’t work.
I tried like this:

  - title: "My Apps"
    icon: "fas://window-restore"
      - "sys/rstudio/rstudio*"

but no luck.
The menu is always empty.
Screenshot 2024-04-10 at 17.15.37

The permission for all folders is 755.
The “Menus based on applications” configuration in the documentation doesn’t mention any other change, anyway, for completeness, the configuration in the nginx_stage.yml is the default one:

  dev: '~%{owner}/%{portal}/dev/%{name}'
  usr: '/var/www/ood/apps/usr/%{owner}/gateway/%{name}'
  sys: '/var/www/ood/apps/sys/%{name}'

I’m not sure that’s helping. Do you have anything else I can check for more useful info of the issue?

The subapp path is /local and should only hold the form and submit YML files.

So you’d have something like this. Subapps use the same template/* directory, but only forms and submit ymls will be applied.


Got it. My idea was to have a “nested” structure for apps. This way I could better organize applications owned by different groups (giving permissions on specific subfolders) and build different menus based on profiles pointing to subfolders.
If this configuration only works with sub-apps then it can’t be used it for my use case.
By the way, it would probably makes sense to add this info in the documentation.
Many thanks for your help!