Unable to download a file from the file tab

I have a user who is trying to download a file from OpenOndemand to their desktop from the files tab and they are getting an “invalid byte sequence UTF-8”

What would be causing this and is there a way to fix that?

Hey, sorry for the issue. What version of OOD are you using? What browser was the user using to make the download?

2.0.29 and I do not know the browser they are using. Most likely firefox. But I will get that info.

They were using Microsoft Edge.

Ok, I’ll have to grab that browser and take a look. I can say we don’t do any testing against that browser so it could be. Does the issue persist on Chrome or FF for the user, if they can use those?

I don’t think they tried that. They did try Safari on an iPad and it came up with the same error. We don’t recommend anything but Chrome and Firefox for OpenOndemand right on the dashboard. If it is a MS Edge issue don’t go any further because we can have them use Globus. But I’d like to know if it is an issue with the browser and not the file manager.

I just grabbed Edge and downloaded a small file with bad UTF-8 with no issues.

Looking at the files_controller it looks like this is handled here:

This may be a bug on our end though, because the response.stream.write(chunk) method is used to write the file contents to the HTTP response in chunks, which could potentially cause issues with encoding if the chunks are not properly encoded.

I’m going to play around with some larger files that have some bad encoding to see if I can replicate this.

I’ve been playing with this more and downloading files as large as 1GB filled with broken UTF-8 but have not been able to replicate the issue. Do you know how large this file was by chance?

Yea are you able to share the file in question?

I will see if I can get a copy of the file.

I just found out that they were trying to download a directory not a file.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.